Troubleshooting

From www.chip-community.org
Jump to: navigation, search


There are two CHIP troubleshooting guides, this one, and NTC's guide. If you can't find the answer you need in either place, post your quesiton to the CHIP message board.



Overheating

Many CHIP users have asserted that their CHIPs have overheated, leading to unreliable operation including abrupt shutdowns. According to NTC employees, the vast majority of these cases fall into two categories:

  1. Power problems, where the CHIP draws a power spike (surge) and the power supply's voltage drops, leading to the power controller shutting the board down. See #Abrupt Shutdowns.
  2. Flash memory problems, which NTC claims can be somewhat temperature-dependent. I.e. the problem can happen more often when CHIP warms up, but it's not a "temperature problem", it's a flash problem. The solution is not to cool the CHIP, it is to repair the flash. See #CHIP Hangs.

It is a bad idea to put your CHIP in the refrigerator, or worse, the freezer. This is because when you take it out, there is a risk of condensation, which can corrode the connections and even cause damage to parts if power is applied while damp.


Abrupt Shutdowns

This is about sudden shutdowns, with both LEDs turning off. See #CHIP_Hangs (below) if your LEDs stay lit, but CHIP doesn't operate.

Does your CHIP get part-way through its boot process and then suddenly shut down? Or perhaps it boots all the way, but when you try to do anything network-intensive (like try to browse the web), it dies. Or perhaps when you plug a peripheral into the USB bus. These symptoms are almost always caused by inadequate power supplied to CHIP and its peripherals.

A complicating problem is that many power supplies, especially USB chargers, lie on their ratings! A supply claiming to provide 5V 1A may not actually provide even half that. You might find one supply rated at 1A unable to reliably power CHIP, while another rated at 750 mA works fine. We also have confirmation that a low-quality MicroUSB cable can result in degraded power.

If you are very sure that your power supply and cable are capable of supplying, say, 2A, and you are still experiencing abrupt shutdowns, then it could be that your CHIP plus peripherals require more than 900 mA during peak usages. In that case, CHIP's internal current limiter will shut CHIP down. If CHIP plus peripherals need more than 900 mA, use one of the power designs that provide more power than the MicroUSB can supply.

See Care and Feeding#Power for a short-and-sweet treatment of power issues.

See Power for a more-complete treatment of power issues.


Video DIPs blank

Maybe your CHIP gets partway through booting and then the screen blanks (i.e. loses signal). But when you boot without the video DIP (e.g. when using composite), it boots fine.

First question: when this happens, are CHIP's LEDs still turned on? If so, then post to the message board because the wiki doesn't have a troubleshooting section for that situation yet.

The rest of this section assumes that when the problem happens, CHIP's LEDs also go dark. You've got a power problem.

The first thing you need to do is determine if your power supply is insufficient, or if the CHIP plus DIP peaks at more than 900 mA of current. Don't worry, this can be checked without test equipment. The method of testing is to temporarily turn off CHIP's current limiter. This can be done with the "axp209_nolim" startup script; see this post for instructions. NOTE: NTC recommends against plugging CHIP into your laptop if you've turned off CHIP's current limiter.

Go ahead and install the "axp209_nolim" startup script, and reboot. Does it fix the problem? If so, then you need a new power design. Many people succeed simply by using a battery in addition to their charger. Others use Queso, or some other method of connecting power to CHG-IN. See Power for different power alternatives.

But if you get the same problem even with the "axp209-nolim" startup script, then your power supply is insufficient for the CHIP plus DIP. Be aware that the labels on many power supplies lie about the current they can supply. You should get a supply rated at 2A ... that really can deliver 2A.

When you've finished the experiment and corrected the problem (e.g. added a battery, or replaced the power supply) and now it works, please remove the "axp209-nolim" startup script. Keeping it disables a potentially important protection for your laptop, should you need to re-flash your CHIP. Plugging CHIP into your laptop's USB with the current limiter disabled puts your laptop at risk. (Note that the degree of risk is a subject of disagreement on the message board.)

Finally, if you are very unlucky, the experiment may have led you to replace your power supply, and then when you remove the "axp209-nolim" startup script, the problem comes back. In other words, some people have BOTH problems (needing a better supply and needing a new power design).


CHIP Hangs

This is about when CHIP stops operating, but the LEDs stay turned on. See above if your LEDs turn off.

If the CHIP hangs during a flash download, or while booting, a possible culprit is corrupted flash. See this thread. Chances are good that you just need to do the boot repair, which is quick and easy. If you still experience hangs with both LED lights still on, then you may need to re-flash your operating system, using the same tool.


Slow or Unreliable Wireless

Several people have noticed that SSH connections to CHIP periodically pause for a second for no discernible reason. Some have seen network-intensive operations fail (e.g. I've had "apt-get update" fail).

It turns out that CHIP's wireless hardware is set with power management turned on. This presumably reduces power consumption, but also introduces slow-downs and failures.

See https://github.com/fordsfords/wlan_pwr/tree/gh-pages for a solution.

One resolution to the "Secrets were required but not provided" when connecting to wifi from a command line https://bbs.nextthing.co/t/resolution-to-secrets-were-required-but-not-provided-and-a-follow-up-question/5120/1


Wireless Connectivity

When you use nmtui to configure the interface with a static IP, if you enter the IP in the address field without a netmask, it assumes a /32. This can interfere with connectivity. Use the netmask appropriate for your network (/24 for most home networks). If you forgot to set it earlier, you can edit the interface using nmtui to update it.


Trouble Flashing

There are two different types of NAND used for C.H.I.P manufacture, and earlier versions of the flash software weren't as good at detecting this, leading to issues (the 'dreaded FEL lockup' mode, for example.)

There are 2 proven/tested methods of flashing your C.H.I.P. :

  • The GUI method, which needs Chrome or Chromium. This is the method most users will use and works on Windows, OsX, and Linux.
** This software was updated in early November 2016; if you have an earlier version, or you don't know what version you have, and are having trouble - try to uninstall and reinstall.  This has solved many users issues.
  • The Script method, which needs (as of November 2016, needs Ubuntu; Debian reported to work; other Linuxen/Unixen/OS: will require much work to adapt.)

See this related wiki page: flashing from the command line

Success has been reported by many users in the forum in November 2016 with both these methods. If you are unable to flash successfully with the GUI flasher and need more diagnostic output, try the script method. It _should_ be possible to use this method from an Ubuntu live CD/DVD/USB stick without changing your operating system, however the author of the document above hasn't had time to test this yet. (If you have done it and have success, please tell Truck on the forum)


Earlier solutions (prior to November 2016) had the following suggestions, which may be useful but may actually be red herrings with the new tools:

  • Mac: cannot flash with "fastboot". See this.
  • Cannot flash full GUI CHIP OS. You need to use the "-f" option (fastboot). For example:
./chip-update-firmware.sh -d -b stable-gui -f
Note that "-f" does not work on Mac machines. See this.
  • Even buildroot and debian flashings hang. You may need to run the boot repair tool. Mac users see this.
  • Waiting for fel ........ TIMEOUT, Linux desktop - Might need boot repair. Or look at fremder's post.

Mac Problems

See Ubuntu on Mac: boot repair and flashing full GUI


Running custom applications

Error 'No such file or directory'

When you want to run an application (built for arm by you or anyone else), it can happen that you get this error, even though the application file is clearly there:

root@chip:/usr/sandbox# ls -l helloChip
-rwxr-xr-x 1 root root 5016 Apr  7 12:53 helloChip
root@chip:/usr/sandbox# ./helloChip
-bash: ./helloChip: No such file or directory

The reason is that the application needs some libraries, and bash cannot find them on C.H.I.P.

The solution is to check the needed libraries with ldd, and then make sure the libs are in place:

root@chip:/usr/sandbox# ldd helloChip
        linux-vdso.so.1 (0xbee77000)
        libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb6ed6000)
        /lib/ld-linux.so.3 => /lib/ld-linux-armhf.so.3 (0x7f644000)

It turns out that "/lib/ld-linux-armhf.so.3" doesn't exist. But it's the same thing as "/lib/ld-linux.so.3", so it is easy to fix with a symbolic link:

root@chip:/usr/sandbox# ln -s /lib/ld-linux-armhf.so.3 /lib/ld-linux.so.3
root@chip:/usr/sandbox# ./helloChip
hello world from C.H.I.P.
note: "easy to fix" and 'correct to fix' aren't the same thing. This is a _temporary_ fix; remember you did it as it may be a problem later when you try to update your C.H.I.P. - also you'll have to do it again if you ever reflash your C.H.I.P.

Severely Degraded Video

Some people have reported severe video problems: blurriness, wavy display, bars or bands, flashing on and off.

Note that composite video will be somewhat blurry, especially on a larger screen. But the image should be stable.

One possible problem is the cable. If you're not using a cable from NTC, it might be wired wrong. See http://docs.getchip.com/#about-the-trrs-connector

Another possible problem is the video format. CHIP ships with NTSC format, which is correct for the U.S., Canada, and a few other countries. But much of the rest of the world uses PAL format. See http://docs.getchip.com/#ntsc-or-pal


Calibrating Touchscreen on PocketChip

See the page on how to calibrate the touchscreen.

PocketChip Keyboard Issues

FN+key failures fall into two categories:

If you're using the default PocketChip GUI interface and the FN keys don't type anything or type the wrong things, open the Terminal and run
xmodmap ~/.Xmodmap

If you've disabled the GUI and are running in text mode, it's a little more complicated. Try Enabling the FN Keys.

Apt-get Failures

A user was running "apt update" which was reporting "could not resolve" errors, and some other errors as well.

To fix this he moved (and later removed) the cache located at "/var/lib/apt/lists" and ran an "apt update", which fixed the issue.

I2C / TWI problems

If you're hooking up an IC to the I2C (TWI) that can't run at the default clock speed of 100 KHz, you may find yourself having trouble communicating with the IC (reading unreliable data).

You can slow down the I2C bus to suit these devices.

Follow these steps to change the clock speed of I2C on CHIP:

1. Install device-tree-compiler

sudo apt update
sudo apt install device-tree-compiler

2. Back up your current device tree

sudo cp /boot/sun5i-r8-chip.dtb /boot/sun5i-r8-chip.dtb.bak.wtf.bbq.sauce

3. Configure the I2C device tree entry for the desired speed. Choose accordingly based on whichever I2C port you're using (in this case I'm using /dev/i2c-2 so I'll change i2c2)

sudo fdtput --type u /boot/sun5i-r8-chip.dtb i2c2 clock-frequency 50000

4. Reboot

sudo systemctl reboot

Have Questions?

This Wiki is not a discussion board. It is the collected knowledge and experience of other CHIP users. A Wiki is NOT a good tool for a lot of Q&A, so if you can't find a solution to your problem here, or if you don't understand something that is written, go to the CHIP message board. If even that doesn't get you what you need, you can send email to NTC's official customer support from their home page by clicking their "Contact" link.